FeaturedNews

PMDG release 777-300ER for P3D v4 – ‘NGX is “more-or-less” finished’

PMDG just released the -300 expansion for P3D v4, and state that the NGX is more-or-less finished, this is very exciting. here are the full details from PMDG

Captains,

A few moments ago we released the PMDG 777-300ER Expansion Package compatibility update to make it cooperate with Prepar3D v4.  If you already own the 77W for Prepar3D v3, simply visit PMDG eCommerce and download a new copy of the installer.

IMPORTANT:  Uninstall the older version you already have installed, then run the new installer.  (No other action is required.)

The NGX is “more-or-less” finished and we will have more information on it’s availability after the US holiday, today.  (I just re-read that, and I know how some like to parse what I say… so…  We will have more information for you after the US holiday- and the release will come shortly there-after…)

I am replacing the 01JUL17 announcement thread because it became a bit cluttered by going in 228 different directions, and I wanted to “re-clear” everyone who hasn’t already read the latest information in relation to the PMDG 747-400 and PMDG 777-200LR/F and PMDG 777-300ER product lines.

Quick Recap:  We just completed a major modernization of our installation process, and as such we have rebuilt the installers for the PMDG 747-400 Queen of the Skies IIand the PMDG 777-200LR/F.  We are using this rebuild as an opportunity to issue a global reset for all customers, and for that reason, on 01JUL17 we advised that everyone uninstall whatever version of these products that they had installed, and download and install the most current versions.

Does this apply to you?:  Run the PMDG Operations Center, select your product, and check the version number.  If it tells you that you don’t have the most current version number, then yes- you should do this update.

Is it urgent?:  No.  Do it whenever suits you.  Over the next couple of weeks we will begin issuing micro-updates for all of our products- and the micro-updater will tell you need to download a full installation if you haven’t gotten to the required version.

I’m confused!:  Don’t sweat it.  Whenever it is convenient for you- run the Operations Center.  Click on your product, click the VERSIONS button and if you need an update it’ll tell you.  Don’t overthink it!

Should I uninstall First?:  Yes.  Uninstall your PMDG product, download a new copy, then reinstall.

Do I need to do anything with my license?:  Not unless the software asks you to do something…

I think that covers everything for tonight…  My head desperately needs a pillow….

Tags

Leave a Reply

avatar
  Subscribe  
Notify of
Back to top button
Close
Close

Adblock Detected

Please support the site by disabling your adblocker